← Back to Mixpanel History
none✓ Resolved
Degraded Query API Performance impacting US Projects
Status
resolved
Duration
3h 39m
Updates
3
Coverage
3 articles
📰 RELATED ARTICLES
Mixpanel incident resolved: Degraded Query API Performance impacting US Projects
Resolved: Degraded Query API Performance impacting US Projects
Jan 24, 2026 →
Mixpanel incident update: Degraded Query API Performance impacting US Projects - now monitoring
Update: Degraded Query API Performance impacting US Projects
Jan 24, 2026 →
Mixpanel outage: Degraded Query API Performance impacting US Projects
Breaking: Degraded Query API Performance impacting US Projects
Jan 24, 2026 →
INCIDENT TIMELINE
✓ ResolvedSat, Jan 24, 2026, 06:05 PM
This incident has been resolved.
monitoringSat, Jan 24, 2026, 04:28 PM
A fix has been implemented and we are monitoring the results.
identifiedSat, Jan 24, 2026, 04:02 PM
We are continuing to work on a fix for this issue.
identifiedSat, Jan 24, 2026, 02:25 PM
Mixpanel is experiencing degraded Query API performance, resulting in HTTP 500 responses when querying or saving reports for projects with US residency. Projects with EU and IN residency remain unaffected. Our engineering team is working on a resolution.
📊 TECHNICAL DETAILS
Internal ID
b7e16f06-7b6f-4cdd-8623-eb3a7bc19171
External ID
0w1jq1ckmlwn
🕐 Started
Sat, Jan 24, 2026, 02:25 PM
🔄 Last Updated
Sat, Jan 24, 2026, 06:05 PM
✓ Resolved
Sat, Jan 24, 2026, 06:05 PM
NONE
Impact Level
3h 39m
Total Duration
3
Status Updates
✍️
Auto-generated by ScribePilot.ai
AI-powered content generation for developer platforms. Fact-checked by our editorial system and grounded with real-time data.