← Back to Twilio History
minor✓ Resolved

User Authentication Identity API High Latency for Verizon in United States

TwilioTue, Feb 24, 2026, 07:20 AM
Status
resolved
Duration
6h 55m
Updates
4
Coverage
3 articles

📰 RELATED ARTICLES

Twilio incident resolved: User Authentication Identity API High Latency for Verizon in United States
Resolved: User Authentication Identity API High Latency for Verizon in United States
Feb 24, 2026
Twilio incident update: User Authentication Identity API High Latency for Verizon in United States - now monitoring
Update: User Authentication Identity API High Latency for Verizon in United States
Feb 24, 2026
Twilio outage: User Authentication Identity API High Latency for Verizon in United States
Breaking: User Authentication Identity API High Latency for Verizon in United States
Feb 24, 2026

INCIDENT TIMELINE

✓ ResolvedTue, Feb 24, 2026, 02:15 PM
This incident has been resolved.
monitoringTue, Feb 24, 2026, 12:16 PM
We have observed a recovery in User Authentication Identity for Verizon in the United States and are monitoring service stability. We will provide another update in 2 hours or as soon as more information becomes available.
monitoringTue, Feb 24, 2026, 10:16 AM
We have observed a recovery in User Authentication Identity for Verizon in the United States and are monitoring service stability. We will provide another update in 2 hours or as soon as more information becomes available.
investigatingTue, Feb 24, 2026, 08:20 AM
Twilio customers may be experiencing User Authentication Identity API high latency for Verizon in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
investigatingTue, Feb 24, 2026, 07:20 AM
Twilio customers may be experiencing User Authentication Identity API high latency for Verizon in the United States. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.

📊 TECHNICAL DETAILS

Internal ID
88bd522f-cc10-4a82-87e0-771be185df3f
External ID
p2bl066116kk
🕐 Started
Tue, Feb 24, 2026, 07:20 AM
🔄 Last Updated
Tue, Feb 24, 2026, 02:15 PM
✓ Resolved
Tue, Feb 24, 2026, 02:15 PM
MINOR
Impact Level
6h 55m
Total Duration
4
Status Updates
Affected Components
Lookup SIM SwapLegacy Identity MatchAndAttributes
✍️
Auto-generated by ScribePilot.ai
AI-powered content generation for developer platforms. Fact-checked by our editorial system and grounded with real-time data.