← Back to Twilio History
minor✓ Resolved

SMS Delivery Delays from Twilio to Liberty Mobile Puerto Rico

TwilioTue, Feb 24, 2026, 04:24 AM
Status
resolved
Duration
4h 21m
Updates
3
Coverage
3 articles

📰 RELATED ARTICLES

Twilio incident resolved: SMS Delivery Delays from Twilio to Liberty Mobile Puerto Rico
Resolved: SMS Delivery Delays from Twilio to Liberty Mobile Puerto Rico
Feb 24, 2026
Twilio incident update: SMS Delivery Delays from Twilio to Liberty Mobile Puerto Rico - now monitoring
Update: SMS Delivery Delays from Twilio to Liberty Mobile Puerto Rico
Feb 24, 2026
Twilio outage: SMS Delivery Delays from Twilio to Liberty Mobile Puerto Rico
Breaking: SMS Delivery Delays from Twilio to Liberty Mobile Puerto Rico
Feb 24, 2026

INCIDENT TIMELINE

✓ ResolvedTue, Feb 24, 2026, 08:45 AM
This incident has been resolved.
monitoringTue, Feb 24, 2026, 06:50 AM
We are observing recovery in SMS delivery delays when sending messages to Liberty Mobile network subscribers in Puerto Rico. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
investigatingTue, Feb 24, 2026, 05:24 AM
We are experiencing SMS delivery delays when sending messages to Liberty Mobile network subscribers in Puerto Rico. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
investigatingTue, Feb 24, 2026, 04:24 AM
Twilio customers may be experiencing SMS delivery delays from Twilio to Liberty Mobile network subscribers in Puerto Rico. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.

📊 TECHNICAL DETAILS

Internal ID
6ca3c404-642a-4f7a-8dd2-deddf4ee140b
External ID
ksx9xfs7x289
🕐 Started
Tue, Feb 24, 2026, 04:24 AM
🔄 Last Updated
Tue, Feb 24, 2026, 08:45 AM
✓ Resolved
Tue, Feb 24, 2026, 08:45 AM
MINOR
Impact Level
4h 21m
Total Duration
3
Status Updates
Affected Components
SMS, Latin America
✍️
Auto-generated by ScribePilot.ai
AI-powered content generation for developer platforms. Fact-checked by our editorial system and grounded with real-time data.