← Back to Twilio History
minor✓ Resolved

SMS Delivery Failures to MTN Network in Cameroon

TwilioMon, Jan 19, 2026, 05:34 PM
Status
resolved
Duration
6d 6h
Updates
11
Coverage
2 articles

📰 RELATED ARTICLES

Twilio incident resolved: SMS Delivery Failures to MTN Network in Cameroon
Resolved: SMS Delivery Failures to MTN Network in Cameroon
Jan 26, 2026
Twilio incident update: SMS Delivery Failures to MTN Network in Cameroon - now monitoring
Update: SMS Delivery Failures to MTN Network in Cameroon
Jan 25, 2026

INCIDENT TIMELINE

✓ ResolvedMon, Jan 26, 2026, 12:10 AM
This incident has been resolved.
monitoringSun, Jan 25, 2026, 10:20 PM
We are observing successful SMS delivery to MTN network in Cameroon. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
investigatingSun, Jan 25, 2026, 01:22 AM
We continue to experience SMS delivery failures to MTN network in Cameroon still. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available
investigatingSat, Jan 24, 2026, 01:36 AM
We continue to experience SMS delivery failures to MTN network in Cameroon still. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available
investigatingFri, Jan 23, 2026, 01:36 AM
We continue to experience SMS delivery failures to MTN network in Cameroon still. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available
investigatingThu, Jan 22, 2026, 01:55 AM
We continue to experience SMS delivery failures to MTN network in Cameroon still. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available
investigatingWed, Jan 21, 2026, 01:56 AM
We continue to experience SMS delivery failures to MTN network in Cameroon still. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available
investigatingTue, Jan 20, 2026, 08:40 AM
We continue to experience SMS delivery failures to MTN network in Cameroon still. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 16 hours or as soon as more information becomes available.
investigatingTue, Jan 20, 2026, 12:40 AM
We continue to experience SMS delivery failures to MTN network in Cameroon still. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
investigatingMon, Jan 19, 2026, 08:45 PM
We are experiencing SMS delivery failures to MTN network in Cameroon still. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
investigatingMon, Jan 19, 2026, 06:36 PM
We are still experiencing SMS delivery failures to MTN network in Cameroon. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
investigatingMon, Jan 19, 2026, 05:34 PM
We are experiencing SMS delivery failures to MTN network in Cameroon. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.

📊 TECHNICAL DETAILS

Internal ID
57f38a9d-49f5-466c-ba5d-c2e35cc4e131
External ID
46lygxtw49mj
🕐 Started
Mon, Jan 19, 2026, 05:34 PM
🔄 Last Updated
Mon, Jan 26, 2026, 12:10 AM
✓ Resolved
Mon, Jan 26, 2026, 12:10 AM
MINOR
Impact Level
6d 6h
Total Duration
11
Status Updates
Affected Components
SMS, Middle East & Africa
✍️
Auto-generated by ScribePilot.ai
AI-powered content generation for developer platforms. Fact-checked by our editorial system and grounded with real-time data.