← Back to Twilio History
minor✓ Resolved

SMS Delivery Failures To Jawwal In Palestine

TwilioSat, Jan 24, 2026, 11:11 AM
Status
resolved
Duration
1d 13h
Updates
7
Coverage
3 articles

📰 RELATED ARTICLES

Twilio incident resolved: SMS Delivery Failures To Jawwal In Palestine
Resolved: SMS Delivery Failures To Jawwal In Palestine
Jan 26, 2026
Twilio incident update: SMS Delivery Failures To Jawwal In Palestine - now monitoring
Update: SMS Delivery Failures To Jawwal In Palestine
Jan 25, 2026
Twilio outage: SMS Delivery Failures To Jawwal In Palestine
Breaking: SMS Delivery Failures To Jawwal In Palestine
Jan 24, 2026

INCIDENT TIMELINE

✓ ResolvedMon, Jan 26, 2026, 12:25 AM
This incident has been resolved.
monitoringSun, Jan 25, 2026, 10:56 PM
We are observing successful SMS delivery to Jawwal in Palestine. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
investigatingSun, Jan 25, 2026, 06:02 PM
We are still experiencing SMS delivery failures to Jawwal in Palestine. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
investigatingSun, Jan 25, 2026, 01:55 AM
We are still experiencing SMS delivery failures to Jawwal in Palestine. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 16 hours or as soon as more information becomes available.
investigatingSat, Jan 24, 2026, 05:56 PM
We are still experiencing SMS delivery failures to Jawwal in Palestine. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
investigatingSat, Jan 24, 2026, 01:56 PM
We continue to experience SMS delivery failures to Jawwal in Palestine. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
investigatingSat, Jan 24, 2026, 12:02 PM
We continue to experience SMS delivery failures to Jawwal in Palestine. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
investigatingSat, Jan 24, 2026, 11:11 AM
We are experiencing SMS delivery failures to Jawwal in Palestine. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.

📊 TECHNICAL DETAILS

Internal ID
24b4821b-d559-45cd-86af-14fceb707fb3
External ID
472lk245d28w
🕐 Started
Sat, Jan 24, 2026, 11:11 AM
🔄 Last Updated
Mon, Jan 26, 2026, 12:25 AM
✓ Resolved
Mon, Jan 26, 2026, 12:25 AM
MINOR
Impact Level
1d 13h
Total Duration
7
Status Updates
Affected Components
SMS, Middle East & Africa
✍️
Auto-generated by ScribePilot.ai
AI-powered content generation for developer platforms. Fact-checked by our editorial system and grounded with real-time data.