← Back to Twilio History
minor✓ Resolved

Voice Call Post Dial Delay from Twilio Phone Numbers to United States

TwilioMon, Feb 23, 2026, 09:12 PM
Status
resolved
Duration
3h 27m
Updates
3
Coverage
3 articles

📰 RELATED ARTICLES

Twilio incident resolved: Voice Call Post Dial Delay from Twilio Phone Numbers to United States
Resolved: Voice Call Post Dial Delay from Twilio Phone Numbers to United States
Feb 24, 2026
Twilio incident update: Voice Call Post Dial Delay from Twilio Phone Numbers to United States - now monitoring
Update: Voice Call Post Dial Delay from Twilio Phone Numbers to United States
Feb 24, 2026
Twilio outage: Voice Call Post Dial Delay from Twilio Phone Numbers to United States
Breaking: Voice Call Post Dial Delay from Twilio Phone Numbers to United States
Feb 23, 2026

INCIDENT TIMELINE

✓ ResolvedTue, Feb 24, 2026, 12:40 AM
This incident has been resolved.
monitoringTue, Feb 24, 2026, 12:07 AM
Voice Call Post Dial Delay from Twilio Phone Numbers to United States are now operating normally. We will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.
investigatingMon, Feb 23, 2026, 10:12 PM
Twilio customers may continue to experience voice call post dial delay from Twilio Phone Numbers to network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 2 hours or as soon as more information becomes available.
investigatingMon, Feb 23, 2026, 09:12 PM
Twilio customers may be experiencing voice call post dial delay from Twilio Phone Numbers to network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.

📊 TECHNICAL DETAILS

Internal ID
190f1779-b0b6-490c-932c-64b7eb54f384
External ID
jljfsklvm3jg
🕐 Started
Mon, Feb 23, 2026, 09:12 PM
🔄 Last Updated
Tue, Feb 24, 2026, 12:40 AM
✓ Resolved
Tue, Feb 24, 2026, 12:40 AM
MINOR
Impact Level
3h 27m
Total Duration
3
Status Updates
Affected Components
Voice, North America
✍️
Auto-generated by ScribePilot.ai
AI-powered content generation for developer platforms. Fact-checked by our editorial system and grounded with real-time data.